21sta

WordPress使用和个人碎碎念

wordpress升级程序失败显示:无法安装这个包解决方法

从错误本身来看,您在升级wordpress或者安装插件的时候将临时文件存储在系统C:\Windows\TEMP,当你没有这个文件夹的权限的时候就会得到这个错误,一般情况服务器给的权限不够。

解决办法:(它的原理是原理是指定wp的临时文件夹路径,避免默认的文件夹在windows下没有权限。)

打开wordpress根目录下的wp-config.PHP文件
找到如下:

/** WordPress 目录的绝对路径。 */
if ( !defined('ABSPATH') )
define('ABSPATH', dirname(__FILE__) . '/');

在下面增加如下代码即可:

/** 指定WordPress的临时目录 */
define('WP_TEMP_DIR', ABSPATH . 'wp-content/temp');

最后在wp-content文件夹下新建个temp文件夹,然后试试更新功能,就可以了。
转自SEO博客

点赞
  1. JV说道:

    没用过win主机

  2. 懿古今说道:

    学习了,虽然还没有遇到,先学习以备后用

    1. 21sta说道:

      一般是win主机才有的问题,应该是权限没给到

发表评论

电子邮件地址不会被公开。 必填项已用*标注